Since december 2012 Battlestations: Midway is supported by GameSpy no longer. The only one possibility for Midway players is GameRanger. Please visit www.gameranger.com, download Gameranger client and make new account. You can find other Midway players in the Gameranger rooms. BS:M patch 1.1.1 is required to play online battles. Iowa Mission Pack and Midway Modders Mappacks 1 and 2 are recommended.

Performance Help!

Performance Help!

Hello All,
    I am new to Battlestations Pacific but I’m a veteran of Battlestations Midway. I recently purchased a copy BSP for my PC after enjoying many hours of playing BSM over the last few years. The install of BSP went off without a hitch. After defragging my rig and restarting it I fired up the game and starting tweaking my control set up for my joystick. Once that was finished I was ready to play. I started out in the Allied training grounds and everything was going great. Graphics were looking amazing and the sound of my Battleship’s guns was awesome. Then it happened…after about 10 minutes of gameplay my frame rates hit a brick wall. By brick wall I mean I couldn’t even use my mouse to click exit it was so slow. I tried everything I can think of to correct the issue but haven’t had any luck so far. My system specs are listed below…any help or suggestions would be much appreciated.

OS: Windows XP (SP2)
CPU: AMD 64 X2 Dual Core 4200+
RAM: 4 GB
Vid Card: ATI Radeon HD 6850
Sound Card: Sound Blaster Audigy SE
Direct X: 9.0c
ATI Catalyst Control Center:  12.3 (All settings were turned off while playing)
   
I have all the latest drivers for everything listed above…again any help would be great.

Cheers!
Roman_Souljah

Roman_Souljah
Seaman
Activity Points: 30
ranks
useravatar
Offline
4 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

http://www.cpuid.com/

Download this tool and check that your GPU does not overheat. I had this problem at 1 stage and an extra well placed case fan solved it. You should consider getting XP SP3 too at some stage (though I highly doubt this is the cause of your problem as BSP ran fine on XP SP2 my side)

Axis_Crusher
BSmodHQ/Riot Police
Moderator
Activity Points: 10401
ranks
useravatar
Offline
1694 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

I also think of a overheat problem.

When I got my computer to run BSP, I always had computer complete crash after ~10 minutes. Also with any game comparable in power need.

For the little story the seller wouldn't admit this could be the problem when I got it back for guarantee. Argued that he could launch similar power needed programs with no problem on the same computer. I asked him to show me and he launched a video on VLC...He was totally persuaded that a video needed the same resource as a video game as BSP or gta IV running. bj

Oomperial
Great Khan of Pacific
Moderator
Activity Points: 2405
ranks
useravatar
Offline
347 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

GPU won't be a problem, I think, it's a solid card.
Your CPU, on the other hand is kinda low.

Changing your graphic settings to the lowest didn't help?
If so, it's your CPU, if it still freezes it's probably your GPU.

Xfire: thyske
Skype: M0n3yBE
Xbox Live: M0n3yBE
Battlestations: Midway (PC) : M0n3yBE
Company of Heroes : M0n3y

M0n3y
God.
Moderator
Activity Points: 1943
ranks
useravatar
Offline
1141 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

Thanks for the feedback…once again it’s very much appreciated. I see the point that heat could be the issue as my processor is quite a few years old. On the other hand I’m a bit surprised that it would be an issue at all seeing how my processor exceeds the 3Ghz or higher single core processor recommended in the system requirements for BSP. Is it possible that the game only makes use of one core of a dual core processor? I’d also like to think that my vid card is more than capable of handling anything that BSP could throw at it, again based on the system requirements for BSP. I’ve been wrong before though…that’s why I’m grateful for your responses and ideas.
    Two things I’d like to mention that may shed a little light on the situation. First, I’ve noticed that I don’t need to be playing the game in order for the problem to happen. Shortly after starting the game the other day I received a phone call so the game was just sitting at the main menu with the movie playing on the right hand side of the screen. I sat there for about 5 minutes watching it while talking on the phone. After about 10 more minutes the movie started skipping really bad and again my mouse was so sluggish I had to quit out by using Ctrl+Alt+Delete.
    Secondly, I also play Star Wars: The Old Republic which has heavier system requirements than BSP. I can run the game with all graphic settings on high and I’ve played for hours at a time without so much as a hiccup in the game’s performance. The graphics look awesome and the game runs extremely smooth. The Old Republic is the newest game that I’m currently running on my system…which is another reason why I’m confused. You would think that if I were to have any issues it would be with The Old Republic.
I can’t thank you guys enough for the feedback…if after reading this you think of anything else please let me know.

Cheers!
Roman_Souljah

Roman_Souljah
Seaman
Activity Points: 30
ranks
useravatar
Offline
4 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

This is what the site is for. You have ideas or problems, we're here to listen. I too have had my problems, and I got help.

Midway and Pacific as Adm2805

Adm2805
Battlestations Veteran
Commodore
Activity Points: 4172
ranks
useravatar
Offline
735 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

Temperatures my friend.... what are they?

Axis_Crusher
BSmodHQ/Riot Police
Moderator
Activity Points: 10401
ranks
useravatar
Offline
1694 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

Try reducing your graphics and see if there's any difference in temperature.
If the program suggested doesn't work, try SpeedFan.

It's odd, though, that you can run SW:OR smoothly without any problems...

Xfire: thyske
Skype: M0n3yBE
Xbox Live: M0n3yBE
Battlestations: Midway (PC) : M0n3yBE
Company of Heroes : M0n3y

M0n3y
God.
Moderator
Activity Points: 1943
ranks
useravatar
Offline
1141 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

I fried my 9800GT on BSP but other games ran without it overheating

Axis_Crusher
BSmodHQ/Riot Police
Moderator
Activity Points: 10401
ranks
useravatar
Offline
1694 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

Here are my temp readings...

System Idle @ Desktop
GPU = 41 C
CPU = 35 C

At Main Menu in BSP
GPU = 44 C
CPU = 46 C

In Game (as the problem is happening)
GPU = 57 C
CPU = 54 C

Roman_Souljah
Seaman
Activity Points: 30
ranks
useravatar
Offline
4 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

toy with the settings, reduce the resolution and if possible play windowed, if the problem still persist go to Eidos HQ with a shotgun in your hand and ask for some answers. It looks more like something conflicting in BSP then it is your hardware.

Support me on Twitter!

http://twitter.com/Tipsymahn260

Tipsy3000
American Idiota! ;D
Commodore
Activity Points: 943
ranks
useravatar
Offline
1029 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

Yeah, your temps are fine.
I reach over 75 with my GPU on BF3 and it still runs smoothly.

Have you tried re-installing the game?
Do you have the latest drivers for your GPU?

Xfire: thyske
Skype: M0n3yBE
Xbox Live: M0n3yBE
Battlestations: Midway (PC) : M0n3yBE
Company of Heroes : M0n3y

M0n3y
God.
Moderator
Activity Points: 1943
ranks
useravatar
Offline
1141 Posts
User info in posts
Administrator has disabled public posting

Re: Performance Help!

Yea...I did a fresh re-install on Tuesday. I very recently updated my drivers so I sould have the very latest.
Last night I dialed down the graphic settings in game to see if that would help. I pretty much disabled everything...shadows,ocean reflection, etc. Texture and Objects set to medium rather high but I did leave Anti-A at 4x...I'm going to try it again with the Anti-A off and objects and texture set to low and see what happens.

Another thing I noticed last night, after running into my issue in game I quit out and restarted it. I made back to the first Eidos splash screen then it started acting jumpy again...didn't even make it to the main menu.

Roman_Souljah
Seaman
Activity Points: 30
ranks
useravatar
Offline
4 Posts
User info in posts
Administrator has disabled public posting

Board Info

Board Stats:
 
Total Topics:
1690
Total Polls:
69
Total Posts:
23070
Dormant:
User Info:
 
Total Users:
20621
Newest User:
charlibracewell
Members Online:
0
Guests Online:
292

Online: 
There are no members online

Forum Legend:

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked

Login Form

Battlestations Shoutbox

Latest Message: 1 day, 20 hours ago
  • Runsva : are we still talikg about the zyy modding pack??
  • N_Trainz : Yeah I wanted to do this, but the installers were being a pain giving me errors about something. I finally got it working, and just figured out how to make the updater now since it'll be two parts with one containing the misc files and the other mostly the mpak files. It'll be a stand - alone DLC mod just like the Bismarck Mission Pack was. Like I said I plan to have it all completed and uploaded by this weekend
  • Legendary Da : No, no, not problem at all; I am already grateful that you were thinking about this subject, I can wait as long as you need to. Thanks for the help (again), and feel no need to rush this subject; we all know that the life comes first. :)
  • N_Trainz : Hope you won't mind the wait, it'll be worth it if you ask me, and yes I do understand that you can't download due to that cap Mege has. I heard the PM was down, but haven't tried it as I been busy helping the BSmodHQ team with things and then those that are life - in - general.
  • N_Trainz : To Legendary Da: I been trying to work on that actually, what I'm experiencing is the pack size> I already made it a light version of the mod, so hopefully this weekend maybe, might be sooner
  • Legendary Da : To N_Trainz: So, um... I can't exactly download from Mega for some reason; so could u upload that mod to Moddb? I am sorry for making extra work for you, and I TOTALLY understand if u can't upload it again; so, do as you want; I just wanted to say somehow I couldn't dl the mod (btw, why isn't the PM working?). U don't have to post the link either; I'll find it from the site if u upload it. Thanks whatever u do, and so sorry for the extra wish. :/
  • Runsva : Anyone there??
  • Runsva : That is on the zyy modding pack v1.0.3 forum.
  • Runsva : If that hepls...
  • Runsva : The link that I donloaded from is the one message before the last one on page 4 on this forum because all the others are for some reason down.
  • YamatoFavor : Zyy eh... doubt I installed successfully and seems like I lost the build
  • Axis_Crusher : Well I am aware of that mod, but I've never installed it. I'll ask around if I can find someone that successfully installed it.
  • Runsva : The zyy modding pack v1.0.3
  • Axis_Crusher : Just so we're on the same page which mod are you trying to install?
  • Runsva : Game*
  • Runsva : Do i need to make a copy of my gamr folder like Battlestations Midway?
  • Runsva : No I didn't install it into a separate directory, it is in steamapps - - > common like any other steam game.
  • Runsva : pls help me fix it i really want to play this mod :D
  • Runsva : and i copied every file to the mpak folder in the bsp directory, and when i try to run it it just crahes onthe main menu screen
  • Runsva : mpak*

Only registered users are allowed to post

Now Online

None

Birthdays

BusyOCAMPO Send PM
birthday will Friday, 24 February 2017